Cisco Catalyst 2950

From philcrump.co.uk
Jump to: navigation, search

I have currently been loaned 2x Cisco Catalyst 2950 24-port Fast Ethernet L2 Managed Switches.

How to Upgrade Firmware

  • To Delete a directory: delete /force /recursive flash:<directory name>, rmdir <directory name>

How to reset to Factory Defaults

How to Reset Password

Latest Firmware: 12.1(22)EA14 (2nd Nov 2010)

SN: FCZ1025Y17V

Hostname: c2950

MAC Address: 00:18:19:DE:2A:00

IP: 192.168.0.100

FW: 12.1(22)EA14

Console enable password: 'catalyst'/'cisco'

Web Interface: 'administrator' / secret

SN: FOC0626Z0EB

Currently at Telemetricor Ltd.

Hostname: c2950

MAC Address: 00:0A:41:32:40:40

IP: 192.168.0.100

FW: 12.1(22)EA14

Web Interface: 'administrator' / secret

config

Reset to defaults

  1. write erase

[confirm]

  1. reload

[confirm]

.. wait for boot
  1. delete flash:vlan.dat

[confirm] [confirm]

  1. reload

[confirm]

.. wait for boot

> en

  1. configure terminal
.. paste config below
  1. copy system:running-config nvram:startup-config

[confirm]

  1. reload
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$.cfW$ps703gtaXrGVaZxvPWFJx1
enable password secretpassword
!
ip subnet-zero
!
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
spanning-tree vlan 1-4094 priority 61440
!
!         
!         
!         
interface FastEthernet0/1
 switchport mode access
!         
interface FastEthernet0/2
 switchport mode access
!         
interface FastEthernet0/3
 switchport mode access
!         
interface FastEthernet0/4
 switchport mode access
!
interface FastEthernet0/5
 switchport mode access
!
interface FastEthernet0/6
 switchport mode access
!
interface FastEthernet0/7
 switchport mode access
!
interface FastEthernet0/8
 switchport mode access
!
interface FastEthernet0/9
 switchport mode access
!
interface FastEthernet0/10
 switchport mode access
!
interface FastEthernet0/11
 switchport mode access
!
interface FastEthernet0/12
 switchport mode access
!
interface FastEthernet0/13
 switchport mode access
!
interface FastEthernet0/14
 switchport mode access
!
interface FastEthernet0/15
 switchport mode access
!
interface FastEthernet0/16
 switchport mode access
!
interface FastEthernet0/17
 switchport mode access
!         
interface FastEthernet0/18
 switchport mode access
!         
interface FastEthernet0/19
 switchport mode access
!         
interface FastEthernet0/20
 switchport mode access
!         
interface FastEthernet0/21
 switchport mode access
!         
interface FastEthernet0/22
 switchport mode access
!         
interface FastEthernet0/23
 switchport mode access
!         
interface FastEthernet0/24
 switchport mode access
!         
interface Vlan1
 ip address 10.250.0.192 255.255.255.0
 no ip route-cache
!         
ip http server
!         
line con 0
line vty 5 15
!         
!         
end